Unfortunately, Segmentation fault Piwik errors mean that the lower level software has crashed in some unexpected fashion. In this case, most likely PHP or some of its specific modules (PDO, mysqli, etc.). It is possible to overcome this issue by updating these softwares.
If you get the Segmentation fault error, the solution is to:

  • Upgrade Piwik and make sure to use the latest version
  • upgrade PHP to the latest version
  • upgrade PDO (and/or mysqli) to the latest version.
  • you may also try to switch from PDO_MYSQL to MYSQLI in the config/config.ini.php ; edit the line “adapter = […]”
  • if you still get the error, try disabling extensions such as eAccelerator, xcache and/or Suhosin, if you are using one of them.
  • if you still get the segmentation fault error at this point, try the suggestion in this issue (if it works for you, please post a comment in this issue).

You should now have a working Piwik instance that does not crash, congratulations.

Any questions?

Many answers and more information about Piwik You can find here:

We are social

Follow us: