Serious web hosting companies will provide the ability to enable PHP 5.3, either via a config setting in your web host administration panel, or via a .htaccess. If you do not have a server with PHP5 and your web host doesn’t support PHP5, we have partnered with high quality web hosts who provide a pre-loaded Piwik for a small fee.

If your web host supports PHP4 but hasn’t enabled PHP5, it might be possible to enable it manually. Here are the most common ways to enable PHP5; create a .htaccess file in your piwik folder containing

  • version A: AddHandler php5-cgi .php
  • or version B: SetEnv PHP_VER 5
  • or version C: AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

If this does not work, please contact your web host and they should enable the latest PHP version for you.

Any questions?

Many answers and more information about Piwik You can find here:

We are social

Follow us: